Linux Mint Üzerinde QGIS 2.4 Kurulumu (SAGA, GRASS, OTB)

Linux Mint, son zamanlarda en çok tercih edilen masaüstü linux dağıtımı olarak karşımıza çıkmaktadır (http://distrowatch.com/dwres.php?resource=popularity). Masaüstü dizaynı, zengin paket desteği (ubuntu tabanlı olması), kolay anlaşılır yapısıyla bilhassa yeni Linux kullanıcılarının ilk tercihlerinden biri haline getiriyor. Ayrıca menü dizaynı ve kullanılabilirlik açısından Windows kullanıcılarının da aşina olduğu bir yapıya sahip olması popülerliğini arttıran etkenlerin başında gelmektedir.

Yeni başlayan Linux kullanıcılar açısından yazılım kurulumları bazen oldukça zorlu olabiliyor. Hele ki güncel versiyonlara ulaşma, bağımlılık (dependency) sorunları can sıkıcı bir hal alabiliyor. Bu yazımda şuan için son versiyon olan QGIS 2.4 ün Linux Mint 17 üzerinde kurulmasını anlatacağım. Ayrıca SAGA GIS, GRASS GIS, OTB (Orfeo Toolbox) yazılımlarının da kurulmasına ve QGIS Processing Toolbox için entegrasyonuna değineceğim

Ubuntu GIS Deposunu Eklenmesi

Standart Linux Mint depolarında bulunan QGIS paketinin sürümü 2.0 ‘dır. En güncel versiyonu olan 2.4 Chugiak sürümünü kurmak için Ubuntugis (unstable) deposunu kullanacağız. Bu depoda pek çok CBS yazılımının son sürümlerini bulabilirsiniz.

Öncelikle Software Center ‘ı başlatarak ana menüden Edit > Software sources açın.

Açılan pencerede sol taraftan PPAs seçilerek Add a new PPA düğmesine tıklayın ve açılan kutucuğa ppa:ubuntugis/ubuntugis-unstable adresini girin.

Depo eklendikten sonra karşınıza bilgi ekranı gelecektir.

Ardından ilgili depodaki paketlerin listesini almak için Update the cache düğmesine tıklayın. İşlemin tamamlanmasının ardından pencereyi kapatın. Software Center kendiliğinden kapanacak ve yeni paketlerle beraber tekrar açılacaktır.

Kurulum

Software Center arama menüsünden “qgis” yazarak ilgili paketleri listeleyin. İlk sonucu (qgis)  açarak sürümü kontrol ettiğinizde 2.4 olduğunu göreceksiniz.

Öncelikle bu paketi kuracağız. Bu paket temel QGIS için yeterlidir. Fakat Python desteği ve GRASS ‘ı içermez. Bunları ayrı olarak kurmak gereklidir. Sırasıyla python-qgis ve qgis-plugin-grass paketlerini kurarak tam QGIS kurulumunu tamamlayın.

Processing eklentisi QGIS ‘e zengin analiz araçları kazandıran oldukça önemli bir Python eklentisidir. GRASS, SAGA ve Orfeo Toolbox ‘a ait araçları kullanır. Dolayısıyla bu yazılımların sistemde kurulu olması gerekir. GRASS GIS zaten qgis-plugin-grass paketi ile kurulmuş oldu. SAGA GIS (2.1.2) için “saga” paketini kurmanız yeterlidir. Orfeo Toolbox için ise “otb-bin” paketini kurarak kurulum işlemlerini tamamlayın.

Son Rötuşlar

Kurulum işlemleri tamamlandıktan sonra yapmamız gereken son bir adım daha var. Processing Toolbox otomatik olarak analiz kütüphanelerini (GRASS, SAGA, Orfeo) tanıyıp kullanmaya imkan sağlamaktadır. Fakat SAGA araçlarını kullanırken 2.0.8 sürümüne göre işlem yapar. Fakat bizim kurduğumuz sürüm (2.1.2) son versiyon olduğundan dolayı uyumsuzluk çıkaracaktır. Bunu düzeltmek için öncelikle QGIS ‘i başlatıyoruz. Ardından ana menüden Processing > Options and configuration yolu izlenir. Karşınıza gelen pencerede Providers başlığı altındaki SAGA sekmesi açılarak Use SAGA 2.0.8 syntax seçeneği inaktif edilir. Bu işlemi de tamamladıktan sonra Linux Mint ortamında tüm özellikleri aktif bir şekilde QGIS 2.4.0 ‘ü kullanmaya başlayabilirsiniz.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s